スクリプトバージョンのチェック
だまってひらけばぴたりとわかる(^^)。
language属性によってあなたのブラウザが読みに行く(使えるとは限りません^^;;)スクリプトバージョンのチェックです。読みに行ってもブラウザに実行能力がない命令だとエラーになります。
(javascript1と1.0とjavateascriptは存在しないバージョンです^^;;)




<script language="ECMAScript1.0">
<script language="ECMAScript">
<script language="JavaScript2.0">
<script language="JavaScript1.6">
<script language="JavaScript1.5">
<script language="JavaScript1.4">
<script language="JavaScript1.3">
<script language="JavaScript1.2">
<script language="JavaScript1.1">
<script language="JavaScript1.0">
<script language="JavaScript1">
<script language="JavaTeaScript">
<script language="ジャワティーストレート">
<script language="JavaScript">
<script language="JScript">
<script language="LiveScript">
<script language="VBScript">



HTML4.01では、script要素のlanguage属性は
  > この値は言語の識別子ではあるが、
  > 識別子が【インターネットの】標準
  > ではないので、この属性は推奨しな
  > いこととなり、typeを採用する。 
と、なっていて、 type="text/javascript" が推奨されています。 ところが、type属性はスクリプトバージョンではありませんから、 そもそも取り替えは不可能なのです。で、仕様はそれとしても 共存さえしてくれれば良いのに、実は、どのブラウザも共存できないのです(泣)。 Win IE5.5も、Win 4.0 も N6も、MacIEもn4も type="text/javascript" 書いたとたんに language属性が無効になってしまうのです...

つまり、type="text/javascript"を書くと、エラーを回避するためにJavaScript1.3以下のブラウザにマスクするという ようなことはできないということなのです。

<script type="text/javascript" language="JavaScript2.0">
<script type="text/javascript" language="JavaScript1.6">
<script type="text/javascript" language="JavaScript1.5">
<script type="text/javascript" language="JavaScript1.4">
<script type="text/javascript" language="JavaScript1.3">
<script type="text/javascript" language="JavaScript1.2">
<script type="text/javascript" language="JavaScript1.1">
<script type="text/javascript" language="JavaScript1.0">
<script type="text/javascript" language="JavaScript1">
<script type="text/javascript" language="JavaTeaScript">
<script type="text/javascript" language="ジャワティーストレート">
<script type="text/javascript" language="JavaScript">
<script type="text/jscript" language="JScript">
<script type="text/javascript" language="LiveScript">
<script type="text/vbscript" language="VBScript">
<script type="text/vbscript" language="JavaScript"> なんじゃこりゃ



実は、こんなバージョン指定のほうほうも有るのですが、対応しているのは Mozだけで、もちろん今までのブラウザには理解不能です。

<script type="text/javascript;version=2.0" language="JavaScript2.0">
<script type="text/javascript;version=1.6" language="JavaScript1.6">
<script type="text/javascript;version=1.5" language="JavaScript1.5">
<script type="text/javascript;version=1.4" language="JavaScript1.4">
<script type="text/javascript;version=1.3" language="JavaScript1.3">
<script type="text/javascript;version=1.2" language="JavaScript1.2">
<script type="text/javascript;version=1.1" language="JavaScript1.1">
<script type="text/javascript;version=1.0" language="JavaScript1.0">
<script type="text/javascript;version=1" language="JavaScript1">


Maintained by
tato@fureai.or.jp works1997-2002 Toshirou Takahashi